Anti-spam

Minor incident Anti-spam
2023-03-06 20:55 CEST · 10 hours, 38 minutes

Updates

Resolved

The issue has been resolved.

March 7, 2023 · 07:34 CEST
Issue

We are currently experiencing issues on anti-spam and are working on a solution. For relevant updates on the matter, please refer to this site or subscribe to automatic updates.

We apologize for any inconvenience this may cause. Please do not hesitate to contact us on support@itas.dk or phone +45 7020 4066 if you have any questions.

March 6, 2023 · 20:57 CEST

← Back